# ZeyOS REST API — LLM index

## Specs
- REST OpenAPI: /__doc/openapi/api.json
- OAuth 2.0 OpenAPI: /__doc/openapi/oauth2.json
- Simple Auth OpenAPI: /__doc/openapi/auth.json

## Tag index (JSON)
- /ai/openapi/tags.json

## Operations index (JSON)
- /ai/openapi/operations.json

## Servers
- https://cloud.zeyos.com/{INSTANCE}/api/v1 — ZeyOS Cloud

## Authentication
- oauth (oauth2) — OAuth 2.0 Authorization ([RFC 6749](https://tools.ietf.org/html/rfc6749)); use the **[ZeyOS OAuth 2.0 API](https://developers.zeyos.com/oauth2) `POST /oauth2/v1/token`** to obtain a valid bearer token
- token (http) — HTTP Bearer Authentication ([RFC 6750](https://tools.ietf.org/html/rfc6750))
- session (apiKey) — Session Cookie Authentication ([RFC 6265](https://tools.ietf.org/html/rfc6265))

## Tag docs (Markdown)
- accounts (6 endpoints): /ai/openapi/tag.accounts.md
- actionsteps (6 endpoints): /ai/openapi/tag.actionsteps.md
- addresses (6 endpoints): /ai/openapi/tag.addresses.md
- applicationassets (3 endpoints): /ai/openapi/tag.applicationassets.md
- applications (3 endpoints): /ai/openapi/tag.applications.md
- appointments (6 endpoints): /ai/openapi/tag.appointments.md
- associations (6 endpoints): /ai/openapi/tag.associations.md
- binfiles (1 endpoints): /ai/openapi/tag.binfiles.md
- campaigns (6 endpoints): /ai/openapi/tag.campaigns.md
- categories (6 endpoints): /ai/openapi/tag.categories.md
- channels (6 endpoints): /ai/openapi/tag.channels.md
- comments (6 endpoints): /ai/openapi/tag.comments.md
- components (6 endpoints): /ai/openapi/tag.components.md
- contacts (6 endpoints): /ai/openapi/tag.contacts.md
- contacts2contacts (6 endpoints): /ai/openapi/tag.contacts2contacts.md
- contracts (6 endpoints): /ai/openapi/tag.contracts.md
- couponcodes (6 endpoints): /ai/openapi/tag.couponcodes.md
- coupons (6 endpoints): /ai/openapi/tag.coupons.md
- customfields (3 endpoints): /ai/openapi/tag.customfields.md
- davservers (6 endpoints): /ai/openapi/tag.davservers.md
- devices (6 endpoints): /ai/openapi/tag.devices.md
- documents (6 endpoints): /ai/openapi/tag.documents.md
- dunning (6 endpoints): /ai/openapi/tag.dunning.md
- dunning2transactions (6 endpoints): /ai/openapi/tag.dunning2transactions.md
- entities2channels (6 endpoints): /ai/openapi/tag.entities2channels.md
- events (6 endpoints): /ai/openapi/tag.events.md
- feedservers (6 endpoints): /ai/openapi/tag.feedservers.md
- files (6 endpoints): /ai/openapi/tag.files.md
- follows (6 endpoints): /ai/openapi/tag.follows.md
- forks (3 endpoints): /ai/openapi/tag.forks.md
- general (2 endpoints): /ai/openapi/tag.general.md
- groups (3 endpoints): /ai/openapi/tag.groups.md
- groups2users (3 endpoints): /ai/openapi/tag.groups2users.md
- invitations (6 endpoints): /ai/openapi/tag.invitations.md
- items (6 endpoints): /ai/openapi/tag.items.md
- ledgers (6 endpoints): /ai/openapi/tag.ledgers.md
- likes (6 endpoints): /ai/openapi/tag.likes.md
- links (6 endpoints): /ai/openapi/tag.links.md
- mailinglists (6 endpoints): /ai/openapi/tag.mailinglists.md
- mailingrecipients (6 endpoints): /ai/openapi/tag.mailingrecipients.md
- mailservers (6 endpoints): /ai/openapi/tag.mailservers.md
- messagereads (6 endpoints): /ai/openapi/tag.messagereads.md
- messages (6 endpoints): /ai/openapi/tag.messages.md
- notes (6 endpoints): /ai/openapi/tag.notes.md
- objects (6 endpoints): /ai/openapi/tag.objects.md
- opportunities (6 endpoints): /ai/openapi/tag.opportunities.md
- participants (6 endpoints): /ai/openapi/tag.participants.md
- payments (6 endpoints): /ai/openapi/tag.payments.md
- permissions (3 endpoints): /ai/openapi/tag.permissions.md
- pricelists (6 endpoints): /ai/openapi/tag.pricelists.md
- pricelists2accounts (6 endpoints): /ai/openapi/tag.pricelists2accounts.md
- prices (6 endpoints): /ai/openapi/tag.prices.md
- projects (6 endpoints): /ai/openapi/tag.projects.md
- records (6 endpoints): /ai/openapi/tag.records.md
- relateditems (6 endpoints): /ai/openapi/tag.relateditems.md
- resources (3 endpoints): /ai/openapi/tag.resources.md
- services (3 endpoints): /ai/openapi/tag.services.md
- stocktransactions (6 endpoints): /ai/openapi/tag.stocktransactions.md
- storages (6 endpoints): /ai/openapi/tag.storages.md
- suppliers (6 endpoints): /ai/openapi/tag.suppliers.md
- tasks (6 endpoints): /ai/openapi/tag.tasks.md
- tickets (6 endpoints): /ai/openapi/tag.tickets.md
- transactions (6 endpoints): /ai/openapi/tag.transactions.md
- users (3 endpoints): /ai/openapi/tag.users.md
- weblets (3 endpoints): /ai/openapi/tag.weblets.md
